Windows 10 waking with no fix

NZSol

New Member
#1
Im currently running windows 10 home version. Ive been woken up god knows how many nights in a row now due to my computer waking itself from sleep mode for no apparent reason. After surfing through many websites looking for how to find the problem/solution, I discovered that the cause is the "reboot" scheduled task, under the "UpdateOrchestrator" folder (Microsoft-->Windows-->UpdateOrchestrator-->Reboot). From here though I cant do anything as it requires system access to disable the "wake pc to run this task" option. How can I fix this?
 


Neemobeer

Windows Forum Team
Staff member
#2
Well the simple answer would be turn off the computer, or if it's the screen brightness waking you up turn off the monitor. You can prevent a scheduled task from waking up the computer, but as a SYSTEM task I wouldn't recommend editing it. There are ways to gain SYSTEM access.
 


Neemobeer

Windows Forum Team
Staff member
#3
Looking at my UpdateOrchestrator Reboot task, it is not configured to wake the computer. This should be the same for you under the 'Conditions' tab.

The next time it wakes up, open a command prompt and type powercfg /lastwake that should tell you what woke the system up.
 


NZSol

New Member
#4
Its selected alright. I know what Im doing with this stuff. Pics show the info Ive been looking at. The issue is more I shouldnt suddenly be having this problem where before the last update, I never had it
 


Attachments

Neemobeer

Windows Forum Team
Staff member
#5
After testing you shouldn't need any special permissions beyond administrators group membership. Right click the Reboot task > properties > conditions tab and uncheck 'wake the computer to run this task'. Should be good
 


Neemobeer

Windows Forum Team
Staff member
#6
You can also look for task change events to see when it changed with this powershell command

Get-WinEvent -FilterHashtable @{logname='Microsoft-Windows-TaskScheduler/Operational'; id='140'} | ? {$_.Message -like "*Reboot*" }
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#7
Simple way would be PowerOptions > Advanced Settings > Sleep > Allow Wake Timers > Setting: Disabled. ...
 


nmsuk

Windows Forum Admin
Staff member
Premium Supporter
#8
Also on thinking about it, disable wake on lan, as thats known to wake machines randomly
 


NZSol

New Member
#9
nmusk, wake timers and wake on lan are both disabled I already.
Neemobeer, Ive tried going through and doing that but it comes up with the following window. Ive switched it to my username and used my password and that still doesnt work. Using the powershell command you put up doesnt give anything useful either
 


Attachments

davehc

Essential Member
Premium Supporter
#10
Have you looked in the device manager -Network adapters. Right click each and select properties. Then the "power management tab. makes sure you have the option to wake the computer turned off
 


#11
It is all off. The problem is this reboot thing in the task schedular. Its just I have no way of actually disabling it
 


davehc

Essential Member
Premium Supporter
#12
Ok. How about
C:\Windows\System32\Tasks
and seeing if it can be deleted from there?
 


#13
That one worked. Cheers Davehc
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top